27 Feb '13, 2pm

Phusion Passenger 4.0 Release Candidate 2

A few months ago we sat down with a customer who was experiencing seemingly random crashes with Phusion Passenger. These crashes could not be reproduced on any of our systems, but could be reliably reproduced on theirs. The crashes would only manifest under high concurrency scenarios. After a day of intensive investigation, we found that the crash was caused because their systems’ file descriptor limit is much lower than any of our systems’. Phusion Passenger did not always catch out-of-file-descriptors errors, so those errors caused Phusion Passenger to crash. Due to other unrelated issues, relevant error messages could not be printed to the log file and were lost.

Full article: http://blog.phusion.nl/#.US4RtcFpSJI.hackernews

Tweets

Phusion Passenger 4.0 Release Candidate 2:

blog.phusion.nl 27 Feb '13, 2pm

The Nginx version now supports the passenger_app_root configuration option. The Enterprise memory limiting feature has bee...

Phusion Passenger 4.0 Release Candidate 4 – Phu...

blog.phusion.nl 05 Mar '13, 1pm

Today we are pleased to announce Release Candidate 4 of Phusion Passenger 4.0. Last week we said that the open source rele...

Phusion Passenger 4.0 Release Candidate 4:

blog.phusion.nl 05 Mar '13, 11am

Today we are pleased to announce Release Candidate 4 of Phusion Passenger 4.0. Last week we said that the open source rele...

Phusion Passenger 4.0 Release Candidate 4

rubyflow.ru 07 Mar '13, 3pm

Phusion Passenger 4.0 Release Candidate 4