12 Feb '12, 11pm

linecache gem ruby 1.9 compatibility:

This using ruby-head (at the time) ruby 1.9.2-p180. Wasn't working at first. Was failing with the following exception: ----- Installing linecache (0.43) with native extensions /Users/kmtrowbr/.rvm/rubies/ruby-1.9.2-head/lib/ruby/site_ruby/1.9.1/rubygems/installer.rb:533:in `rescue in block in build_extensions': ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError) /Users/kmtrowbr/.rvm/rubies/ruby-1.9.2-head/bin/ruby extconf.rb Can't handle 1.9.x yet *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. Check the mkmf.log file for more details. You may need configuration options. Provided configuration options: --with-opt-dir --without-opt-dir --with-opt-include --without-opt-include=${opt-dir}/include --with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog --without...

Full article: http://isitruby19.com/linecache

Tweets

this is freaking awesome, stumbled across it to...

isitruby19.com 12 Feb '12, 11pm

The Ruby community needs your help. Install Ruby 1.9.1 then try out your favourite gems and provide feedback here. We can ...

Convert Ruby 1.8 to 1.9 hash syntax

robots.thoughtbot.com 11 Feb '12, 10pm

thoughtbot giant robots smashing into other giant robots We are thoughtbot , a web design and development agency in Boston...

Ruby 1.9.3-p125 をリリースした

ruby-lang.org 16 Feb '12, 12pm

a security fixes of the Ruby OpenSSL extension . And many bugs are fixed in this release.

Ruby

tryruby.org 14 Feb '12, 12pm

hackedunit-apn_sender | | your community gem host

rubygems.org 13 Feb '12, 5am

Resque-based background worker to send Apple Push Notifications over a persistent TCP socket. Includes Resque tweaks to al...

Wondering how debug in Ruby? Check this out!

Wondering how debug in Ruby? Check this out!

pivotallabs.com 12 Feb '12, 11pm

Interesting Anecdote: Today, I was with a customer trying to debug cruisecontrol.rb. He uses NetBeans (which was the GUI d...

Do you know Ruby Doctest?

rubylearning.com 11 Feb '12, 7pm

USAGE: rubydoctest [options] rubydoctest parses Ruby files (.rb) or DocTest files (.doctest) for irb-style sessions in com...

Ruby 1.9.3-p125 and 1.8.7-p358 have been released

ruby-lang.org 16 Feb '12, 12pm

Security Fix for Ruby OpenSSL module: Allow "0/n splitting" as a prevention for the TLS BEAST attack. Denial of service at...

git-rails – Tools for using git with #Ruby on #...

nanorails.com 13 Feb '12, 3am

git-rails – Tools for using git with Ruby on Rails by Pascal on February 5, 2008 in git-rails Git-Rails git-rails is a sim...

New gem release: memcached (1.3.7)

rubygems.org 12 Feb '12, 9pm

memcached 1.3.7 An interface to the libmemcached C client. install gem install memcached Download Subscribe Stats Authors ...

roodi | | your community gem host:

rubygems.org 11 Feb '12, 10pm

Roodi stands for Ruby Object Oriented Design Inferometer. It parses your Ruby code and warns you about design issues you h...

any ruby gems for /programmes other than

rubygems.org 14 Feb '12, 3pm

Ruby client library for the BBC Programmes website.

New recommended Ruby version: Ruby 1.9.3-p125 i...

rubyflow.com 16 Feb '12, 10pm

New recommended Ruby version: Ruby 1.9.3-p125 is released Posted by DanielKehoe on February 16, 2012 — 0 comments Ruby 1.9...

Infineon Technologies and Fairchild Semiconduct...

infineon.com 12 Feb '12, 4pm

Neubiberg, Germany – February 7, 2012 – Infineon Technologies and Fairchild Semiconductor today announced the extension of...

Prepare Your App for Rails 4 and Ruby 1.9

engineyard.com 21 Feb '12, 8pm

Well, it had to happen some day. Pour one out for our dearly beloved Ruby 1.8.7. And if you’re still using 1.8.7 for your ...