29 Mar '12, 9pm

@avdi cool comment by @raggi from just 2 years ago on related ticket - pretty much predicting the future

Suppose that we have an app Foo that depends on Bar, no specific version. At this time, running 'gem "foo"' will automatically activate the latest version of "bar". This behavior causes various problems. A concrete example: - Rails 3.0pre depends on Rack 1.1. - Rails 2.3 depends on Rack 1.0. - Thin depends on Rack, no specific version. If all of the above are installed, and one tries to use Thin to start a Rails 2.3 app, then it will fail. Thin's wrapper binary runs 'gem "thin"', which in turn activates Rack 1.1 immediately. When Thin starts Rails 2.3, Rails tries to activate Rack 1.0. As you can see, Thin + Rails 2.3 is completely broken just by having Rack 1.1 installed. This can be solved adding an hypothetical --rack-version=xxx command line option to Thin, which would instruct Thin to activate a specific Rack version during startup so that one can start Rails 2.3 apps...

Full article: http://rubyforge.org/tracker/index.php?func=detail&aid=27...

Tweets

Not too cool to drool: by Don Mendoza Dining ou...

todayonline.com 29 Mar '12, 9pm

Dining out in Singapore has never been more in fashion; more haute, hip and, well, hellishly capricious. And the people lo...

Forecasting tech's future: how high can we go?

eetimes.com 29 Mar '12, 10pm

Forecasting the future of the high tech market is always a tricky undertaking. Customers never want to hear that the indus...