22 May '12, 12am

"Support for Java 7’s invokedynamic"

This is the first preview release of JRuby 1.7. This release represents a tremendous amount of work by dozens of contributors, and there are improvements in every subsystem. Users on Java 7 should start to see gains from invokedynamic, the JVM’s new support for dynamic languages. Users of highly-concurrent applications will see improvements in throughput and raw parallelism. And we have upped our compatibility level to match Ruby 1.9.3.

Full article: http://www.jruby.org/2012/05/21/jruby-1-7-0-preview1.html

Tweets

JRuby 1.7.0.preview1 is out. First release with...

jruby.org 21 May '12, 8pm

JRuby 1.7.0.preview1 is our next installment of the JRuby 1.x series. Please check out our

JRuby 1.7.0.preview1

jruby.org 24 May '12, 2pm

This is the first preview release of JRuby 1.7. This release represents a tremendous amount of work by dozens of contribut...

#JRuby 1.7.0 Preview 1 Released with InvokeDyna...

jruby.org 26 May '12, 4pm

This is the first preview release of JRuby 1.7. This release represents a tremendous amount of work by dozens of contribut...

JRuby Core Team Members Moving to Red Hat

JRuby Core Team Members Moving to Red Hat

rubyinside.com 22 May '12, 4pm

Breaking news! At JRubyConf 2012 (a 3 day JRuby-focused conference in Minneapolis) it has just been announced that JRuby c...

RABL 0.6.12 Released

rubyflow.com 21 May '12, 12am

(Ruby API Builder Language) version 0.6.12 has just been released. RABL is a popular way to craft service or API responses...

jruby-openssl (0.7.7): JRuby-OpenSSL is an add-...

rubygems.org 21 May '12, 10pm

JRuby-OpenSSL is an add-on gem for JRuby that emulates the Ruby OpenSSL native library.

We're teaming with Red Hat on @JRuby

engineyard.com 22 May '12, 4pm

EY sponsors and allows these little teams to flourish and then sets them free. Github, JRuby, Rails 3 initiative. (Not sur...

Net:SSH for #JRuby supports Pageant by using ou...

rubygems.org 18 May '12, 4am

jruby-pageant 1.0.2 This is a convenience gem packaging required JNA/JSCH jars. install gem install jruby-pageant Download...