13 Aug '12, 6am

Defect #11034: TLS configuration broken since 2.0 - Redmine

Since upgrading to 2.0.0 (also verified today on 2.0.1, and svn trunk) the smtp configuration settings for TLS encryption is somewhat broken, as notified by [1]. If a smtp server is configured with both "tls: true" and "enable_starttls_auto: true", this error occurs when trying to send mail: An error occurred while sending mail (SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: unknown protocol) This type of configuration is also the suggested method for configuring gmail in the redmine documentation [2]. As a workaround found by [1], you can remove the "tls: true" part of the configuration, while leaving in "enable_starttls_auto: true". I can also confirm that this workaround works for me, to make gmail & redmine working. [1]: http://mentalized.net/journal/2012/05/08/rails_3_actionmailer_and_google_apps_for_domains/ [2]: http://www.redmine.org/projects/re...

Full article: http://www.redmine.org/issues/11034

Tweets

EmailConfiguration - Redmine

redmine.org 13 Aug '12, 6am

# Outgoing email settings production: email_delivery: delivery_method: :smtp smtp_settings: address: smtp.example.net port...

Blog updated: Mending these broken pieces

Blog updated: Mending these broken pieces

hanzbr.blogspot.com 17 Aug '12, 1pm

Not everytime I smile, I smile from within but the days are getting better. Even if it storms, it doesn't last forever. I'...

7 Things to Turn Off in Facebook | ClappingTree’s Web 2.0

7 Things to Turn Off in Facebook | ClappingTree...

clappingtrees.com 18 Aug '12, 12pm

Privacy > Profile : Control who can see your profile and personal information. Privacy > Search : Control who can search f...