18 Dec '12, 10pm

Periodic reminder to specify dependency versions in your Gemfile:

Periodic reminder to specify dependency versions in your Gemfile:

TL;DR This is your periodic reminder to specify dependency versions in your Gemfile I started updating one of our larger projects at work to use edge Rails. This project uses devise, and the Gemfile declares the dependency like this: gem "devise" The latest version of devise correctly declares its dependency on Railties on ~> 3.1: However, Devise version 1.5.3 does not declare a specific dependency on Rails (or Railties): This means that as I upgrade this application, doing a bundle update pulls in Devise version 1.5.3. This version of Devise is incompatible with the app’s codebase. How do you fix it? Update the Gemfile to include the version number (just like rubygems.org recommends) like this: gem "devise", "~> 2.1.2" Bundling against Rails 4.0 will fail, but at least it will be a fail during bundle time and not during runtime: Bundler could not find compatible versions ...

Full article: http://tenderlovemaking.com/2012/12/18/rails-4-and-your-g...

Tweets

Rails 4 requires at least Ruby 1.9.3 [Rails 4 C...

blog.remarkablelabs.com 18 Dec '12, 3pm

This post is part of a series of 31 Rails 4 articles being released each day in December 2012 . As of June 2013, Ruby 1.8....